Azure - Account Name & Account ID - Reporting Discrepancy
Incident Report for Cloudability
Resolved
This incident has been resolved.
Posted Dec 07, 2022 - 16:36 UTC
Monitoring
Azure confirmed that they resolved the issue, and reexport of November should fix the issue.

Please try creating a fresh one-time export of both the Actual and Amortized cost. You have to follow the below steps 2 times, one for Actual and one for Amortized.

Steps to generate the file:

Login to Azure Portal and click into Cost Management + Billing
Navigate to Settings > Exports
Add an Export. Fill in the export details: Export-Type should be One-Time Export and From-To would be 1 Nov'22 to 31 Nov’22
Use the existing Storage for storing the files
Once done with filling the details, click create.
The export would now be visible. Select the export and click Run-Now. The export creation can take ~ 1hr.
Download the exported file within the newly created export directory and upload it to the directory that's credentialised with Cloudability.

Once the files are in place, processes should automatically then pick up this automatically within 1-2 days (as it is the previous month) but raise a case with Support if you want this done sooner after you have exported
Posted Dec 07, 2022 - 15:07 UTC
Identified
Azure has identified the issue. A fix is currently being implemented and validated by Azure. We will update this page once validation is complete.
Posted Dec 07, 2022 - 02:57 UTC
Investigating
Cloudability has identified an Azure issue with Account Names (Azure Subscription) reporting as "Unassigned", and their respected Account ID's showing as 000, which is impacting Azure reporting in Cloudability starting in November to current date.

We have a high-priority ticket open with Azure to investigate this issue. We will report back with additional updates as they come in from Azure.
Posted Dec 06, 2022 - 15:46 UTC
This incident affected: Americas (Data Collection - Microsoft Azure).