Gov : Cost data ingestion/processing delays since 3rd September

Incident Report for Cloudability

Resolved

This incident has been resolved.
Posted Sep 09, 2026 - 15:04 UTC

Update

We have implemented a fix for this issue and confirmed that data is fully processed for some customers. We continue to monitor the progress to ensure that all data is being processed.
Posted Sep 08, 2026 - 21:27 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 08, 2026 - 17:01 UTC

Investigating

We are currently investigating this issue.
Posted Sep 08, 2026 - 14:58 UTC
This incident affected: US GovCloud (USGOV) - AWS (Data Collection - Amazon Web Services (AWS), Data Collection - Microsoft Azure, Data Collection - Google Cloud Platform (GCP)).