Commitment Recommendations is not populating for AWS

Incident Report for Cloudability

Resolved

This incident has been resolved.
Posted May 20, 2026 - 17:06 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 20, 2026 - 16:38 UTC

Investigating

We are currently investigating this issue.
Posted May 20, 2026 - 14:56 UTC
This incident affected: Americas (US2) - Azure (Commitments), Americas (US) - AWS (Commitments), Europe (EU) - AWS (Commitments), Australia (AU) - AWS (Commitments), Middle East (ME) - AWS (Commitments), India (IN) - AWS (Commitments), Japan (JP) - AWS (Commitments), and Canada (CA) - AWS (Commitments).