Dashboard and Report Slowness
Incident Report for Cloudability
Resolved
This incident has been resolved.
Posted Sep 24, 2020 - 20:32 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 24, 2020 - 19:51 UTC
Investigating
We are currently investigating reports of slow or failing widgets and reports
Posted Sep 24, 2020 - 19:26 UTC
This incident affected: Americas (Web App).