Snowflake Account Sync is affected in Cloudability

Incident Report for Cloudability

Update

We are continuing to work on a fix for this issue.
Posted Sep 04, 2026 - 15:17 UTC

Update

We are continuing to work on a fix for this issue.
Posted Sep 03, 2026 - 16:38 UTC

Identified

Only Snowflake Account Sync is affected. While this is unresolved, Cloudability will not pick up newly created Snowflake accounts, and details for existing accounts are no longer refreshed. The Snowflake credential shows a 'X' against the list accounts permission 'snowflake.list.accounts'

Snowflake Cost jobs are not affected. Cost data continues to be ingested, processed and loaded as normal, and cost dashboards remain accurate.

Once the view is corrected, Account Sync resumes automatically on the next cycle and picks up anything added in the meantime.

Reference Document : https://docs.snowflake.com/en/release-notes/bcr-bundles/un-bundled/bcr-2399
Posted Sep 03, 2026 - 16:34 UTC
This incident affects: Americas (US) - AWS (Reporting), Europe (EU) - AWS (Reporting), Australia (AU) - AWS (Reporting), Americas (US2) - Azure (Reporting), India (IN) - AWS (Reporting), Japan (JP) - AWS (Reporting), and Canada (CA) - AWS (Reporting).