Azure Savings Plans Missing Data

Incident Report for Cloudability

Resolved

We have implemented a fix for this issue.
Posted Jun 23, 2025 - 17:18 UTC

Update

We are continuing to work on a fix for this issue.
Posted Jun 19, 2025 - 12:25 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 18, 2025 - 16:55 UTC

Investigating

We are seeing a mismatch in Azure Savings Plan data and are working on a fix. If testing goes well the fix should be live by the end of the week.
Posted Jun 18, 2025 - 16:10 UTC
This incident affected: Americas (Reporting), Europe (EMEA) (Reporting), and Australia (APJ) (Reporting).