Anomaly Detection Intermittent Load Issues

Incident Report for Cloudability

Resolved

This incident has been resolved.
Posted Jul 09, 2026 - 20:48 UTC

Monitoring

We have identified the issue, released the fix, and are now monitoring.
Posted Jul 09, 2026 - 20:15 UTC
This incident affected: Americas (US2) - Azure (Anomaly Detection), Americas (US) - AWS (Anomaly Detection), and Europe (EU) - AWS (Anomaly Detection).