Cloud billing GCP customers are experiencing delays receiving new cost data

Incident Report for Cloudability

Resolved

This incident has been resolved. GCP team confirmed that they fixed the issue with delayed new cost data, and the data recovery is completed.
Posted Aug 18, 2025 - 07:34 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Aug 11, 2025 - 08:31 UTC

Update

We are continuing to investigate this issue.
Posted Aug 05, 2025 - 10:27 UTC

Investigating

We are currently investigating this issue.
Posted Aug 04, 2025 - 06:56 UTC
This incident affected: US GovCloud (USGOV) - AWS (Data Collection - Google Cloud Platform (GCP)), Americas (US) - AWS (Data Collection - Google Cloud Platform (GCP)), Europe (EU) - AWS (Data Collection - Google Cloud Platform (GCP)), Australia (AU) - AWS (Data Collection - Google Cloud Platform (GCP)), and Middle East (ME) - AWS (Data Collection - Google Cloud Platform (GCP)).