Cost reporting delay for GCP

Incident Report for Cloudability

Resolved

The Engineering team (Apptio) has validated the data in Cloudability and found that everything looks good.
Posted May 02, 2025 - 03:41 UTC

Update

The issue has been identified and a fix is being implemented by GCP Team.
Posted Apr 29, 2025 - 03:32 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 29, 2025 - 03:21 UTC

Update

GCP team confirmed that they are experiencing an issue with the Cloud Billing and customers may not be receiving new cost data since 25 April 2025. They are currently investigating the issue.
Posted Apr 28, 2025 - 17:40 UTC

Investigating

Engineering team has investigated the issue, and the delay is from GCP end. We are working with the GCP team.
Posted Apr 28, 2025 - 15:58 UTC
This incident affected: Americas (Reporting), Europe (EMEA) (Reporting), Australia (APJ) (Reporting), and Middle East (ME) (Reporting).