Resolved
Service restoration activities related to the AWS ME-Central region outage are ongoing, and the team continues to make steady progress.
At this stage, we will be transitioning away from updates on the public status page. Moving forward, any additional updates or communications will be shared directly through individual support cases to provide more specific and relevant information.
If you have any questions or require further assistance, please continue to engage with our support team through your existing case.
We appreciate your continued patience and understanding.
Posted Mar 17, 2026 - 17:08 UTC
Update
The Apptio Engineering team continues to make steady progress copying the RDS snapshots from the AWS Middle East data center (AWS ME-Central) to the disaster recovery environment.
As AWS services continue to recover, the snapshot transfer process is progressing smoothly and we are seeing positive momentum in the recovery activities.
Our team remains actively engaged and is working closely with AWS while monitoring progress closely. We will continue to share updates as additional milestones are reached or as new information becomes available.
Posted Mar 12, 2026 - 02:56 UTC
Update
The Apptio Engineering team continues to work on copying the RDS snapshots from the AWS Middle East data center (AWS ME-Central) to the disaster recovery location (AWS ME-South).
During this process, we encountered stability issues affecting some of the AWS services required to complete the migration. The issue has been prioritized with AWS, and we are actively working with AWS Support to investigate and resolve the service instability impacting the snapshot transfer.
We will continue to closely monitor the situation and provide further updates as we receive additional information or progress from AWS.
Posted Mar 10, 2026 - 07:44 UTC
Update
The Apptio Engineering team is continuing work to copy RDS snapshots from the AWS Middle East data center (AWS ME-Central) to the disaster recovery location (AWS ME-South). We have encountered stability issues with some of the AWS services required to complete the migration. We are in close contact with AWS Support and are working to to resolve the issues. We will continue to monitor progress and share additional updates as more information becomes available.
Posted Mar 09, 2026 - 01:32 UTC
Update
The Apptio Engineering team is continuing work to copy RDS snapshots from the AWS Middle East data center (AWS ME-Central) to the disaster recovery location (AWS ME-South). Due to the high volume of data being transferred out of ME-Central, we do not currently have an estimated time of completion. We remain in close contact with AWS Support and are working to optimize the copy process. We will continue to monitor progress and share additional updates as more information becomes available.
Posted Mar 07, 2026 - 19:32 UTC
Update
The Apptio Engineering team continues to work on copying RDS snapshots from the AWS Middle East region (ME-Central) to the designated disaster recovery site (ME-South). The volume of data being transferred out of ME-Central remains substantial, which makes it difficult to project a completion time at this stage.
We are actively collaborating with AWS Support and exploring ways to improve the efficiency of the copy process. Our teams will keep monitoring the operation closely and provide further updates as new information becomes available.
Posted Mar 06, 2026 - 23:53 UTC
Update
The RDS snapshot copy operations are still progressing at a very slow pace. Our team is actively working with AWS Support to resolve the delay, and AWS has indicated that the slowdown is likely due to extremely high export traffic across regions, which is affecting snapshot copy performance. At this time, the availability of the RDS snapshots remains the primary blocker to completing full service recovery. In preparation for restoration, our team has configured the AWS environment in the Bahrain (ME-SOUTH-1) region so that recovery activities can begin immediately once the snapshots become available. We are continuously monitoring the snapshot copy process and are ready to initiate restoration as soon as the snapshots become available. We will continue to provide updates as more information becomes available.
Posted Mar 06, 2026 - 00:12 UTC
Update
The latest update regarding the recovery of services impacted by the ongoing AWS service disruption is that RDS snapshot copy operations are still progressing at a very slow pace more than 36 hours after initiation. Our team is actively working with AWS Support to investigate the delay, and AWS has indicated that the slowdown is likely due to extremely high export traffic across regions, which is affecting snapshot copy performance. At this time, the availability of the RDS snapshots remains the primary blocker to completing full service recovery. In preparation for restoration, our team has already configured the AWS environment in the Bahrain (ME-SOUTH-1) region so that recovery activities can begin immediately once the snapshots become available. We are continuously monitoring the snapshot copy process and are ready to initiate restoration as soon as the snapshots become available. We will continue to provide updates as more information becomes available.
For the latest AWS status updates:
https://health.aws.amazon.com/health/status
Posted Mar 05, 2026 - 14:39 UTC
Update
The Apptio Engineering team is continuing work to copy RDS snapshots from the AWS Middle East data center (AWS ME-Central) to the disaster recovery location (AWS ME-South). Due to the high volume of data being transferred out of ME-Central, we do not currently have an estimated time of completion. We remain in close contact with AWS Support and are working to optimize the copy process. We will continue to monitor progress and share additional updates as more information becomes available.
Posted Mar 05, 2026 - 06:57 UTC
Update
Engineering is copying the RDS snapshots to our DR location. Due to the high volume of data being moved out of the AWS Middle East data center (AWS ME-CENTRAL), we do not have an ETA for completion. We are in constant contact with AWS Support and are working to optimize the copy process. We will continue to monitor progress and share additional updates as more information becomes available.
Posted Mar 05, 2026 - 00:53 UTC
Update
RDS snapshots are now visible in the AWS console, and the Engineering teams have initiated the snapshot copy process. As this operation is fully managed by AWS services, it is difficult to provide an accurate ETA at this time.
We will continue to monitor the progress and share further updates as more information becomes available.
For the latest AWS status updates: https://health.aws.amazon.com/health/status
Posted Mar 04, 2026 - 12:38 UTC
Update
Since our last update, restoration activities remain impacted by ongoing access issues affecting RDS instances and S3 buckets in the affected region. These constraints limit our ability to retrieve the critical data necessary for full service recovery. We are working closely with AWS to restore stable access to these resources as quickly as possible.
In parallel, our teams are progressing contingency plans, including exploring alternative backup retrieval options and preparing for data replication to the ME-South region to facilitate service recovery.
We will continue to provide updates as additional information becomes available.
For the latest AWS status updates:
https://health.aws.amazon.com/health/status
Posted Mar 04, 2026 - 06:51 UTC
Update
At this time, restoration efforts remain blocked due to continued issues accessing RDS instances and S3 buckets in the affected region. These limitations are preventing the retrieval of critical data required to restore services. We are actively working with AWS to re-establish access to these resources.
In parallel, our teams are collaborating with AWS to evaluate alternative methods for retrieving database backups and replicating data to other regions (ME-South) to support service recovery.
We will continue to provide updates as more information becomes available.
For the latest AWS status updates:
https://health.aws.amazon.com/health/status
Posted Mar 03, 2026 - 23:19 UTC
Update
The Engineering team has successfully deployed the routers in our designated AWS Disaster Recovery (DR) region. However, additional services still need to be brought online, and multiple teams are currently working to restore these services in the DR environment.
At this time, restoration efforts are being blocked due to issues accessing RDS instances and S3 buckets in the affected region. These access limitations are preventing the retrieval of necessary data required to restore services.
The team is actively exploring alternative options to retrieve database backups and replicate data to other regions to proceed with service recovery.
We will continue to share updates as more information becomes available.
For the latest AWS status updates: https://health.aws.amazon.com/health/status
Posted Mar 03, 2026 - 16:24 UTC
Update
Our engineering teams continue to work on restoring services in our designated AWS disaster recovery region following the earlier outage. We will share further updates as more information becomes available.
Posted Mar 03, 2026 - 05:41 UTC
Update
We are actively monitoring the ongoing AWS service disruption in the Middle East region and remain in close communication with AWS. In parallel, our teams are working to restore services in our designated disaster recovery region. We will share further updates as additional information becomes available.
Posted Mar 02, 2026 - 21:59 UTC
Update
We're continuing to monitor the AWS service disruption in the ME region, and are engaged with AWS while we also work to bring up services in an alternate DR region. We will provide additional updates as more information becomes available.
Posted Mar 02, 2026 - 16:39 UTC
Update
The engineering team is actively working to bring up services in an alternate DR region as a mitigation for the ongoing AWS outage in the ME region. We will provide additional updates as more information becomes available.
For the latest AWS status updates: https://health.aws.amazon.com/health/status
Posted Mar 02, 2026 - 13:32 UTC
Update
We're continuing to monitor the AWS service disruption in the ME region, and actively seeking applicable workarounds. We will share updates as we have them.
For the latest AWS status updates: https://health.aws.amazon.com/health/status
Posted Mar 02, 2026 - 04:22 UTC
Update
We’re continuing to monitor the AWS service disruption in the ME region and will share updates as AWS provides them.
For the latest AWS status updates: https://health.aws.amazon.com/health/status
Posted Mar 01, 2026 - 21:16 UTC
This incident affected: Middle East (ME) - AWS (API, Login/SSO (Frontdoor), Web App, Reporting, Container Insights, Advanced Containers (powered by Kubecost), Anomaly Detection, Scorecards, Resource Inventory, Commitments, Savings Automation, Rightsizing, Automation, Financial Planning, Workload Planning, MSP, Data Collection - Amazon Web Services (AWS), Data Collection - Microsoft Azure, Data Collection - Google Cloud Platform (GCP), Data Collection - IBM Cloud (IBM), Data Collection - Oracle Cloud Infrastructure (OCI), Data Collection - Datadog, Data Collection - New Relic, Daily Mail, Report Exports, Saved Reports).