Completed
The scheduled maintenance has been completed.
Posted Sep 17, 2025 - 20:00 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 17, 2025 - 18:00 UTC
Scheduled
We will be conducting scheduled maintenance for Cloudability shared services in our EU and ME regions from 6pm - 8pm UTC Wednesday, September 17. The indicated Cloudability services in the region may be unavailable or return service errors during part or all of the maintenance window.
Posted Sep 12, 2025 - 18:09 UTC
This scheduled maintenance affected: Europe (EU) - AWS (API, Login/SSO (Frontdoor-eu), Web App, Reporting, Container Insights, Anomaly Detection, Scorecards, Resource Inventory, Commitments, Savings Automation, Rightsizing, Automation, Financial Planning, Workload Planning, MSP, Daily Mail, Report Exports, Saved Reports) and Middle East (ME) - AWS (API, Login/SSO (Frontdoor), Web App, Reporting, Container Insights, Anomaly Detection, Scorecards, Resource Inventory, Commitments, Savings Automation, Rightsizing, Automation, Financial Planning, Workload Planning, MSP, Daily Mail, Report Exports, Saved Reports).