Unexpected Reserved Instances Displayed in Cloudability

Incident Report for Cloudability

Resolved

This incident has been resolved.
Posted May 09, 2026 - 15:56 UTC

Monitoring

Engineering has implemented a fix to resolve this issue. We will be placing this ticket in monitoring state prior to closing.
Posted May 09, 2026 - 02:11 UTC

Update

We are continuing to work on a fix for this issue.
Posted May 09, 2026 - 00:16 UTC

Identified

Engineering has identified the issue and is working on a change to remediate the issue.
Posted May 08, 2026 - 23:03 UTC

Update

Engineering is narrowing in on a probable cause tied to a recent change in the US production environment. Investigation and remediation are in progress. Further updates to follow.
Posted May 08, 2026 - 22:28 UTC

Update

We are continuing to investigate this issue.
Posted May 08, 2026 - 21:33 UTC

Update

We are continuing to investigate this issue.
Posted May 08, 2026 - 21:20 UTC

Investigating

Cloudability is actively investigating an issue where Reserved Instance commitments are being displayed that do not match a customer's actual AWS environment. This is also triggering underutilization and expiration alert emails for RIs that should not be reported on.
Posted May 08, 2026 - 21:08 UTC
This incident affected: Americas (US) - AWS (Resource Inventory, Commitments), Europe (EU) - AWS (Resource Inventory, Commitments), Australia (AU) - AWS (Resource Inventory, Commitments), India (IN) - AWS (Resource Inventory, Commitments), Japan (JP) - AWS (Resource Inventory, Commitments), and Canada (CA) - AWS (Resource Inventory, Commitments).