AWS Data for all the customers are recovered from Cloudability end.
Posted Nov 14, 2025 - 06:18 UTC
Investigating
There was an AWS outage affecting Billing operations from November 12, 2025, at 11:30 AM PST until November 13, 2025, at 12:30 PM PST. During this period, AWS experienced issues with Usage Reports, which may have prevented customers from viewing the most recent charges and usage data in their cost and billing reports. According to AWS's latest update regarding this outage, customer data recovery was completed approximately an hour ago. Additionally, Cloudability also encountered delays in processing this data due to the same issue.
Posted Nov 13, 2025 - 08:19 UTC
This incident affected: US GovCloud (USGOV) - AWS (Data Collection - Amazon Web Services (AWS)), Americas (US) - AWS (Data Collection - Amazon Web Services (AWS)), Europe (EU) - AWS (Data Collection - Amazon Web Services (AWS)), Australia (AU) - AWS (Data Collection - Amazon Web Services (AWS)), Middle East (ME) - AWS (Data Collection - Amazon Web Services (AWS)), Americas (US2) - Azure (Data Collection - Amazon Web Services (AWS)), India (IN) - AWS (Data Collection - Amazon Web Services (AWS)), Japan (JP) - AWS (Data Collection - Amazon Web Services (AWS)), and Singapore (SG) - AWS (Data Collection - Amazon Web Services (AWS)).